aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-02-24 04:40:02 -0500
committerJesse Luehrs <doy@tozt.net>2021-02-24 04:40:02 -0500
commitcc06e4fc8557f9c277c3875ca550ea2d567e8599 (patch)
treea6382023eee4681645e7f6fbc66312d0f470d13c /Cargo.toml
parent27aa8c71d7946c3a11f76c7493afb9d827ada4bd (diff)
downloadpty-process-cc06e4fc8557f9c277c3875ca550ea2d567e8599.tar.gz
pty-process-cc06e4fc8557f9c277c3875ca550ea2d567e8599.zip
make the tokio pty backend actually work properly
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c5840e5..005d002 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,7 +11,8 @@ thiserror = "1.0"
async-io = { version = "1.3", optional = true }
async-process = { version = "1.0", optional = true }
-tokio = { version = "1.2", optional = true, features = ["fs", "process"] }
+tokio = { version = "1.2", optional = true, features = ["fs", "process", "net"] }
+futures = { version = "0.3", optional = true }
[dev-dependencies]
smol = "*"
@@ -22,4 +23,4 @@ default = ["backend-std"]
backend-std = []
backend-async-std = ["async-io", "async-process"]
backend-smol = ["async-io", "async-process"]
-backend-tokio = ["tokio"]
+backend-tokio = ["tokio", "futures"]