aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-02-23 00:17:01 -0500
committerJesse Luehrs <doy@tozt.net>2021-02-23 00:17:01 -0500
commitf3e8046eff473aa9bf940b7fbd156cf3dfbfa352 (patch)
treea6b3ed53e89556cd801a49a0619ba37e4c397be6 /Cargo.toml
parentacb3681ee251599af194c8555344edc65750ef14 (diff)
downloadpty-process-f3e8046eff473aa9bf940b7fbd156cf3dfbfa352.tar.gz
pty-process-f3e8046eff473aa9bf940b7fbd156cf3dfbfa352.zip
also create separate pty structs per backend
for now, they are identical, but i will change them to be specialized next
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 27e5bf1..6357d07 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,6 +9,7 @@ libc = "*"
nix = "0.17"
thiserror = "1.0"
+async-io = { version = "1.3", optional = true }
async-process = { version = "1.0", optional = true }
tokio = { version = "1.2", optional = true, features = ["process"] }
@@ -16,3 +17,4 @@ tokio = { version = "1.2", optional = true, features = ["process"] }
default = ["std"]
std = []
+async-std = ["async-io", "async-process"]