aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..04b3fcc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+from setuptools import setup, find_packages
+
+setup(
+ name="termcast_server",
+ version="0.1.0",
+ description="allow users to broadcast their terminals for others to watch",
+ url="https://github.com/doy/python-termcast-server",
+ author="Jesse Luehrs",
+ author_email="doy@tozt.net",
+ license="MIT",
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Environment :: Console",
+ "License :: OSI Approved :: MIT License",
+ "Topic :: Terminals :: Terminal Emulators/X Terminals",
+ ],
+ packages=find_packages(),
+ entry_points={
+ "console_scripts": [
+ "termcast_server=termcast_server:main",
+ ],
+ },
+)