aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2023-07-16 16:10:36 -0400
committerGitHub <noreply@github.com>2023-07-16 16:10:36 -0400
commiteb9a55f3fd20d01543b764e0b8b0c69056632ec0 (patch)
tree19174ed26ead9ca765dd619dc8654dd399b009c9 /Cargo.toml
parent8aa7e36a4f2746b314b0a582f3c59cc8b6b03ca2 (diff)
parent66cf6aea2d2fc355543470dab762211d9c8ad306 (diff)
downloadrbw-eb9a55f3fd20d01543b764e0b8b0c69056632ec0.tar.gz
rbw-eb9a55f3fd20d01543b764e0b8b0c69056632ec0.zip
Merge pull request #115 from quexten/feature/websocket-notifications
Implement basic websocket support
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 778e9d4..ef700e2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,6 +27,8 @@ clap_complete = "4.1.5"
daemonize = "0.5.0"
directories = "5.0.0"
env_logger = "0.10.0"
+futures = "0.3.28"
+futures-channel = "0.3.28"
futures-util = "0.3.27"
hkdf = "0.12.3"
hmac = { version = "0.12.1", features = ["std"] }
@@ -57,6 +59,8 @@ totp-lite = "2.0.0"
url = "2.3.1"
uuid = { version = "1.3.0", features = ["v4"] }
zeroize = "1.5.7"
+rmpv = "1.0.0"
+tokio-tungstenite = { version = "0.18.0", features = ["rustls-tls-native-roots"] }
[package.metadata.deb]
depends = "pinentry"