aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-03-06 18:45:50 -0500
committerJesse Luehrs <doy@tozt.net>2021-03-06 18:45:50 -0500
commita4bca446049fd488af29dd5ec26f953845e8e4fe (patch)
treefa7f129e5b27c00f29b4f33edbc31f2c68d89fda /Cargo.toml
parente358c58826b1732763970848c0c6d77f12ef5e5a (diff)
downloadtextmode-a4bca446049fd488af29dd5ec26f953845e8e4fe.tar.gz
textmode-a4bca446049fd488af29dd5ec26f953845e8e4fe.zip
split into sync and async implementations
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1007f0d..08b72cd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,3 +8,13 @@ edition = "2018"
itoa = "0.4"
terminal_size = "0.1"
vt100 = "0.9"
+
+blocking = { version = "1.0", optional = true }
+futures-lite = { version = "1.11", optional = true }
+
+[features]
+default = []
+async = ["blocking", "futures-lite"]
+
+[dev-dependencies]
+smol = "1.2"