aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-10-27 08:30:41 -0400
committerJesse Luehrs <doy@tozt.net>2019-10-27 08:30:41 -0400
commitf900d0952cb94c88b33f85e9885ae00d6e56cdb5 (patch)
tree1172b36fd076755ad5a381a51fffa324ad2a7abb /Cargo.toml
parent649450762eff2d71371e176534fbe64752a3284e (diff)
downloadttyrec-f900d0952cb94c88b33f85e9885ae00d6e56cdb5.tar.gz
ttyrec-f900d0952cb94c88b33f85e9885ae00d6e56cdb5.zip
make tokio features optional
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 39d925f..739575e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,10 @@ keywords = ["ttyrec"]
categories = ["parser-implementations"]
[dependencies]
-futures = "0.1.29"
+futures = { version = "0.1.29", optional = true }
snafu = "0.5"
-tokio = "0.1.22"
+tokio = { version = "0.1.22", optional = true }
+
+[features]
+default = ["async"]
+async = ["tokio", "futures"]