aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 39d925f..739575e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,10 @@ keywords = ["ttyrec"]
categories = ["parser-implementations"]
[dependencies]
-futures = "0.1.29"
+futures = { version = "0.1.29", optional = true }
snafu = "0.5"
-tokio = "0.1.22"
+tokio = { version = "0.1.22", optional = true }
+
+[features]
+default = ["async"]
+async = ["tokio", "futures"]