aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-11-23 13:17:55 -0500
committerJesse Luehrs <doy@tozt.net>2019-11-23 13:33:41 -0500
commitdf312db3c428e7e8936c5ad6846629236bcb6240 (patch)
treebb8ca39f256cf4605cacd78782f80fdbb0e82ec6 /Cargo.toml
parentcd94e2ccb2272286fd0e2bc8ae67db2fba5276e5 (diff)
downloadvt100-rust-df312db3c428e7e8936c5ad6846629236bcb6240.tar.gz
vt100-rust-df312db3c428e7e8936c5ad6846629236bcb6240.zip
make unicode normalization optional
it's not always necessary or desired, and adds quite a lot to the binary size (for instance, the problem it solves is pretty much non-existent in web browsers, and wasm builds are also very sensitive to code size)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7ec13a4..3b79b41 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,10 +12,13 @@ keywords = ["terminal", "vt100"]
categories = ["command-line-interface", "encoding"]
license = "MIT"
+[features]
+default = ["unicode-normalization"]
+
[dependencies]
itoa = "0.4"
enumset = "0.4"
log = "0.4"
-unicode-normalization = "0.1"
+unicode-normalization = { version = "0.1", optional = true }
unicode-width = "0.1"
vte = "0.3"